Summary
Though more advanced and accurate programs exist, Ecotect is great due to its ease of use and superior graphic interface. The software was designed by Andrew Marsh, Co-Founder and Head of Research & Development at Square One. Marsh is an architect, and designed the software for architects, not for engineers.

Ecotect is a tool for architect’s to test their designs. It is not a validation tool to extract absolute values at end of project. It shouldn’t be used to determine the amount of energy used, i.e. watts per day, etc. The tool is best used to compare schemes. Some more accurate programs include DOE-2 and EnergyPlus.

Ecotect uses a simpler algorithm called the admittance method for its thermal calculations. This is an internationally regarded method used by engineers (CIBSE = The Chartered Institute of Building Services Engineers) and designers. Other programs use ASHRAE formulas. However, even the most accurate software is using the same weather files. Weather files are usually averages over 30 years. Each month represents the one that best matches the average, i.e. May of 2003, March of 1997.

The software should be used at the very beginning of design, in parallel with other 3d models. It will never be able to replace your cad drawings. The ideal scenario is to use the tool as you would a study model or sketch, and perform quick analyses to the model, and subsequently change your design.

Hardware Requirements
- A graphics card with 224mb is good for the openGL requirements.

Download and install Ecotect
- Purchase and download the software at http://www.squ1.com/buynow. You will need to first install a trial version, and then install the full version. I also suggest that you download and install version 5.6 Beta from www.symphysis.net/squ1/Ecotect_v560_rc1.zip.

Square One Tutorials
- Follow the link to http://squ1.com/archive/ecotect/tutorials/tutorials.htm. Here you will find a number of tutorials. Please complete the following:
  o Simple House – we will do this tutorial together
    ▪ Before doing the Simple House tutorial, change your units temporarily to metric, i.e. select SI Units and millimeters. These should revert back next time you open Ecotect. You should also change your grid settings to a different grid, such as 1000 x 1000. Make sure your snap distance is set to 1000.
  o Classroom – do this one on your own
  o Thermal Performance – Introduction – we will do this together.

Starting a New Project
- Go to the Project Tab
Load your weather file. If you don’t have the weather file, download it from the EnergyPlus website - http://www.eere.energy.gov/buildings/energyplus/cfm/weather_data.cfm, and convert the .epw file to a .wea file using Weather Tool (licensed copy). Several .wea files are available on Square One’s website - http://www.sq1.com/downloads/weatherdata.

Under Site Location,
- Set your latitude and longitude. You can find this information by using Google Earth.
- Set the north offset. You should always model with Architectural North up.
- Select the local terrain

Basic Navigation and User Preferences
- Panning, zooming and orbiting - in the 3d editor tab:
  - right click to orbit
  - hold down the middle mouse button to pan
  - use the scroll wheel to zoom in and out
- Zooming
  - Use the buttons in the lower right hand corner to zoom to grid, zoom extents, etc.
- Grid
  - Check your grid settings by going to the model settings toolbar. Select an appropriate grid size, for example, 4’ x 4’.

User Preferences
- Go to User Preferences by clicking on File | User Preferences, or Shift+Ctrl+P. click on the localization tab.
- Go to the Cursor Snap tab. Select Align, Orthographic, Grid, Points, Mid-Points, and Intersections. These can also be changed by clicking on the lower left hand corner of your screen. You can also use the following shortcuts – A, C, G, I, L, M, O, and P to toggle the snaps on and off. Set the Snap Distance to 1’ and Snap Angle to 15° (The default unit of measure is feet, and not inches, so if you type 1, then the program assumes this to be 1’)
- Under Modeling settings, change the selection highlight to Fat Line. You can also change your selection highlight to a different color, but if you do this, don’t select yellow or red. You can change your background color on this screen.
- Under General, select Custom, and in the right box, select the following units of measure (some have been left out):
  Dimensions – feet
  Surface area - square feet
  Volume – Cubic Feet
  Mass/Weight – Pounds
  Temperature – Fahrenheit
  Power/Work – Watts
  Energy/Heat – Watt Hours
  Illuminance – Lux
  Thermal Resistance – US R-Value
  Thermal Conductance – US U-Value
  Thermal Conductivity – Watts/Meter Kelvin
  Density – Pounds/Cubic Foot
  Velocity – Meters per Second
  Flow Rate – Cubic Feet/Second
  Heat Gains – Watts/Meter Squared
  Energy/Area – Watt Hours/Meter Squared
  Angles – Degrees (°)
- Make sure that Model Dimensions are set at Feet and Inches, and Currency symbol is set to $
Visualisation Settings
- Try changing the background to white
- Try changing the OpenGL Settings to Pencil or Fuzzy Sketch. Try increasing and decreasing the sketchiness.

Shadow Settings
- Try displaying shadows [F10]. Change the date and time, and see how the shadows change.
- Try displaying the Daily Sun Path and Annual Sun Path by toggling the boxes at the top of Shadow Settings. Again, try changing the date and time, and see how the sun position changes.
- Another handy function is the View from Sun Position button. This is useful when trying to design a shading device optimized for a certain date/time. From this view, if you can't see the window through the shading device, then no solar radiation will penetrate that window at that time/date.

Zones
- Zones are similar to layers in other programs such as AutoCAD or photoshop. However, they differ in that they should represent thermal zones.
- When to create zones, and when should they be thermal?
  - Shading devices should be on the outside or their own non-thermal zone. They won’t be accounted for in the thermal analysis but will be considered when analyzing solar radiation.
  - Basement and attics should be their own thermal zone.
  - You should create a zone for each room in your building. However, it is possible to combine multiple rooms into one zone. It is also possible to divide one room into multiple zones. For example, when two bedrooms are directly adjacent to each other, these could be modeled as one zone, and the wall between them as a partition.
  - If closed, stairs can be modeled as their own thermal zone – vertical circulation.
  - Patios are not conditioned and should not be thermal.
- Partitions are used to separate spaces within one thermal zone. Partition element only account for thermal mass, and won’t add to solar radiation.
- The zone management tab (on right) is similar to layer manager in other programs.
  - You can show/hide zones (light bulb). When hidden, items are not displayed, but are still part of the calculations.
  - You can also turn zones on and off (sunshine), they are no longer in the calculations when off
- You can also create groups. For example, you can create a group for each floor. Then allocate the zones into the appropriate group.

Modeling
- It is possible to import models for daylighting and shading analysis studies.
- For thermal studies, you should model directly in Ecotect.
- Every zone needs to be closed. If you imagine that it was filled with water, there should be no leaks.
- Wall thicknesses are not necessary for thermal analysis. There are two techniques for dealing with wall thicknesses. Either model all zones as touching (recommended) or create non-touching zones with slack space between them. If tracing a plan, for example, you can choose the center line of all interior walls, and the exterior edge of perimeter walls.
- Stairs
  - Stairs should be modeled with a void in the ceiling of the zone below and a void in the floor of the zone above.
Each riser should be modeled as a plane. You only need to model the treads. Remember to keep the model simple.

While modeling, you should check your surface normals, by clicking on Display -> Surface Normals [Ctrl + F9]. You can turn these off by clicking Display -> Model [F9]. It's easiest to isolate the zones to help see the arrows. Ensure that these always point to the exterior. To reverse normals, click on Modify -> Reverse Normals [Ctrl + R].

Moving Items
- Use the Move icon (upper left)
- Use the nudge command (very useful). The nudge command will move the item a default number of units in the axis you type, using the buttons, x, shift+x, y, shift+y, z, shift+z. X moves the item over the amount of units specified under Cursor Snap.

Child Objects
- Use a panel to model a sliding door
- To insert a child object, such as a window, door, or void, first select the wall, and then press the insert button. You can also select the item, and RMC Insert -> Child Object.

Roofs
- Use the pitched roof icon for pitched roofs
- Create a roof from scratch by using planes
- To link items (parent and children), select the items to be linked and click Ctrl + K.

Readings
- It is highly recommended that you read Andrew Marsh's article, entitled, Thermal Modelling: The ECOTECT Way at http://naturalfrequency.com/articles/thermalelements.
- The help file also has a good article called Thermal Modelling.

Using Nodes
- One can use nodes of each plane to modify the geometry. To turn nodes on, select an item, and click F3. This will highlight all nodes of selected item. From here, you can select nodes by clicking on them, using a window to highlight multiple nodes, or using the control and shift button to add or delete nodes from your selection set.

Scripts
- Scripts can be useful for a number of functions. We will review using a script to create a movie.

Keys and Keystrokes commonly used
F3 Select nodes
F4 Isolate the current zone
F5 Plan view
F6 Side view
F7 Other side view
F8 Perspective view
F9 Check normals - all arrows should be facing out
x / shift x Nudge object in this axis by grid snap (shift x nudges in the negative direction)
y / shift y Nudge object in this axis by grid snap (shift y nudges in the negative direction)
z / shift z Nudge object in this axis by grid snap (shift z nudges in the negative direction)
ctrl – tab Toggles between tools, i.e. 3d editor, visualization, etc.
space If you select the common line, the spacebar allows you toggle through all adjacent elements (i.e. Floor, ceiling, walls)

General Items
- There are a finite number of undos, around 5-7. As with any program, save often, and create new versions of your model when appropriate.
- The Default button actually means Save as Default, not reset values to Default.

**Assign Materials**

- **Readings**
  - In the help menu, search for the title, *Material Assignments Panel*
  - In the help menu, search for the title, *Thermal Properties - Opaque Materials*

- **To edit a material,** double click on it the material in the Material Assignments tab (right).
  - Before changing a material, first change the name and description under Properties.
  - Then click Add New Element at the lower left.

- **To edit a material:**
  - Make changes manually. Values for common U-values, Admittance, Solar Absorption, Thermal Decrement, and Thermal Lag are shown in the reading, *Thermal Properties - Opaque Materials* above. Additional information can be found in Steven Szokolay’s *Introduction to Architectural Science: The Basis of Sustainable Design*, in Tables D1.3 and D1.4 in the Appendix.
  - Use the Layers tab to graphically change the makeup of your material. Make sure to Apply Changes and Calculate Thermal Properties. Take note of the figures before and after. You will need to update the thermal lag manually. Consult the tables listed above.

- **Primary vs. Alternate Materials**
  - By default, primary and alternate materials are the same.
  - For walls, roofs, floors, and ceilings - alternate materials are useful when you have overlapping zones. The alternate material is selected when two zones overlap.
  - For windows, doors, panels, voids, appliances, and sources, the alternate material is used with Object Activation. This can be used to open a window or turn on a heater.